Đăng Ký
Kết quả 1 đến 9 của 9
  1. #1
    thuong1041987
    Guest

    PLC S7-400 và sự cố

    Chào mọi người!
    Mình đang làm 1 dự án về s7-400, quản lý 7 con ET 200m. bus redundant, cấu trúc đk phân tán có các lỗi sau đây xuất hiện.
    1. khi 1 con ET hoặc TP 170 bị mất nguồn thì treo cả hệ thống, phải reset lại PLC mới được
    2.Giá trị lưu tốc hiển thị về trên wincc khác với thực tế. cụ thể là trên wincc hiển thị 350m3/h còn thực tế chỉ khoảng 250m3/h. bộ phát xung đã được kiểm nghiệm chính xác.

    Bác nào có thể cho em biết được nguyên nhân của các lỗi trên được ko? Nếu đưa được ra hướng khác phục thì tốt quá.
    Cám ơn mọi người nhé!

  2. #2
    Thành viên Đồng
    Ngày tham gia
    Mar 2011
    Đang ở
    Nếu có vấn đề gì hỏi thì làm ơn đưa lên diễn đàn nhé
    Bài viết
    1,880
    Thanks
    159
    229 lượt trong 198 bài viết
    Coi lại chương trình coi, và quan sát hiện tượng nói ra cụ thể chút, chứ chỉ thế không thì khó bắt bệnh lắm
    Cung cấp Hidden Content ,Hidden Content ,vật tư tự động hóa cũ và mới
    Liên hệ: Hidden Content
    website: Hidden Content
    __________________________________________________ ___________________
    Phone: 0912888729 - 0985888729
    Y.M: codientuhd

  3. #3
    diendt
    Guest
    Về vấn đề con hệ thống bị ngắt khi ET và TP mất nguồn thì bạn cần bổ xung thêm 1 số hàm che ngắt lỗi phần mềm( mất các địa chỉ định nghĩa qua ET) lỗi truyền thông (bus kết nối ra et và tp)... và có khả năng cả lỗi mất phần cứng nữa, theo k.no của tớ thì hầu như hệ nào cũng phải bổ xung các hàm chức năng che ngắt này.

  4. #4
    Thành viên cấp 3
    Ngày tham gia
    Apr 2011
    Đang ở
    quận 12, TpHCM
    Bài viết
    225
    Thanks
    1
    6 lượt trong 6 bài viết
    mình có ý ntn:

    1. bạn tạo các OB từ OB80 đến OB87 + OB121 + OB122 download vào PLC xem sao.
    2. giám sát giá trị đưa về, tính toán lại -> nạp lại chuong trình.

    có kết quả gì thì báo cho mọi người biết nhá.
    Công Tử Bụi :Hidden Content :

  5. #5
    Little PLC

    Ngày tham gia
    Mar 2011
    Đang ở
    Mọi câu hỏi hãy đưa lên diễn dàn. Tôi không dùng hộp thư riêng.
    Bài viết
    3,123
    Thanks
    255
    1,051 lượt trong 552 bài viết
    http://www.mediafire.com/?q2e8jd14wqod1p9
    lỗi gì thì lỗi chứ lỗi card MMC mà ko xử lý được thì cũng .... ^^ vì thế share anh em phần mềm sửa lỗi card MMC
    Mục này dùng chung cho cả 300/400 để để 2 nơi luôn ^^ cho anh em đọc bên nào cũng biết để xử lý.
    Hidden Content

    Hidden Content

    Trần Văn Hiếu
    Email: Hidden Content
    Sđt: (+84)987 - 338 - 334

  6. #6
    thuong1041987
    Guest
    Vâng! cảm ơn mọi người đã nhiệt tình. Các lỗi kia mình đã khắc phục hết rồi bây h chỉ còn duy nhất lỗi ET là bị treo PLC thôi. Với lại ko phải lần nào mất cũng bị treo, chỉ thỉnh thoảng thôi, mình cũng đã hỏi 1 số chuyên gia siemens, thì họ bảo do MMC của mình để là ROM họ cho mượn cái card của họ để up thành RAM, mình đã thử nhưng kết quả vẫn thế chỉ giải quyết được lỗi redundant thôi, ngày trước còn bị lỗi cả redundant mà nghĩa là 1 con PLC bị Stop thì con redundant ko tự động chuyển sang run. Nhưng bây h lỗi treo PLC vẫn chưa khắc phục được, do lâu nay công việc bận quá ko vào diễn đàn được. Anh em thông cảm nhé!

  7. #7
    thuong1041987
    Guest
    Trích dẫn Gửi bởi congtu7677 Xem bài viết
    mình có ý ntn:

    1. bạn tạo các OB từ OB80 đến OB87 + OB121 + OB122 download vào PLC xem sao.
    2. giám sát giá trị đưa về, tính toán lại -> nạp lại chuong trình.

    có kết quả gì thì báo cho mọi người biết nhá.
    Các khối OB từ OB80 đến OB87 + OB121 + OB122 đã có hết rồi trù OB84 là chưa có. Nhưng mình nghĩ có thêm OB84 cũng ko có gì thay đổi đâu. Bởi vì bây h họ ko cho mình thử nữa vì mình đã thử nhiều lần rồi, bây h sửa cái là phải chạy luôn cơ. Khó khăn đây, mình cũng đã mất khá nhiều thời gian về vấn đề này rồi.

  8. #8
    Thành viên cấp 3
    Ngày tham gia
    Mar 2011
    Bài viết
    109
    Thanks
    0
    11 lượt trong 8 bài viết
    cái này bạn phải nối dây chống nhiễu hệ thống thật tốt !
    ý kiến nhỏ !!!
    chúc thành công !

  9. #9
    Thành viên cấp 3
    Ngày tham gia
    Mar 2011
    Bài viết
    109
    Thanks
    0
    11 lượt trong 8 bài viết
    dây mạng lan niếu bạn dùng dây việt nam thì không tốt đâu !
    lúc trước mình có làm công ty có con s7-400 vì lý do gì không biết đổi sang dây lan của việt nam sản xuất , kết quả như trên !
    không báo mất kết nối giữa scanda nhưng không điều khiển được , kết quả tụi chuyên gia đức qua nó không nói chỉ lấy kéo cắt không thương tiết .
    ý kiến nhỏ !!!
    chúc thành công !

Tag của Chủ đề này

Đánh dấu

Quyền viết bài

  • Bạn Không thể gửi Chủ đề mới
  • Bạn Không thể Gửi trả lời
  • Bạn Không thể Gửi file đính kèm
  • Bạn Không thể Sửa bài viết của mình
  •  
Back to Top